// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^\s+"(?<id>[0-9]+)"\s+"(?<path>.+)"$"#).unwrap();
let string = "\"LibraryFolders\"
{
\"TimeNextStatsReport\" \"1613549278\"
\"ContentStatsID\" \"8305207799611222323\"
\"1\" \"E:\\\\Games\\\\SteamLibrary\"
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}