$re = '/(?s)^.*?(?=\(Reuters\)\s*-)/m';
$str = 'Some rubbish ... (Reuters) - Text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;