import re
regex = re.compile(r"(?s)^.*?(?=\(Reuters\)\s*-)", flags=re.MULTILINE)
test_str = "Some rubbish ... (Reuters) - Text"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)