re = /(?s)^.*?(?=\(Reuters\)\s*-)/m
str = 'Some rubbish ... (Reuters) - Text'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result