#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)NSLocalizedString\((.*)\s*,\s*(.*)\)"
Local $sString = "// With text and comment" & @CRLF & _
"NSLocalizedString(@"Example Text", @"Example Comment");" & @CRLF & _
"" & @CRLF & _
"// With text and no comment" & @CRLF & _
"NSLocalizedString(@"Example, text", nil) " & @CRLF & _
"" & @CRLF & _
"// With text and comment with paranthesis" & @CRLF & _
"NSLocalizedString(@"Example text", @"Example (with paranthesis) comment") " & @CRLF & _
"" & @CRLF & _
"// With property and no comment" & @CRLF & _
"NSLocalizedString(test, nil)" & @CRLF & _
"" & @CRLF & _
"// With property and comment" & @CRLF & _
"NSLocalizedString(test, @"Example comment")" & @CRLF & _
"" & @CRLF & _
"// Inline" & @CRLF & _
"NSLocalizedString(@"Error", nil) NSLocalizedString(@"Change settings", @"Option to change HTTP Post settings") NSLocalizedString(@"Cancel", nil)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")