package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(((https?:\/\/)|(www\.))()[^\s]+)`)
var str = `http://google.com/q=search<p>dfgdfg</p>
https://www.google.com
http://www.google.com
www.google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}