import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((https?:\\/\\/)|(www\\.))()[^\\s]+)";
final String string = "http://google.com/q=search<p>dfgdfg</p> \n\n"
+ "https://www.google.com\n"
+ "http://www.google.com\n"
+ "www.google.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}