// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(((https?:\/\/)|(www\.))()[^\s]+)").unwrap();
let string = "http://google.com/q=search<p>dfgdfg</p>
https://www.google.com
http://www.google.com
www.google.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}