re = /^(?!\d{9}$).*$/m
str = '123456789
12345678
1234567890
12a345
123abc789
987654321
111111111
222222222
abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end