using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MIDI-(?<std_building_type>[a-zA-Z]{1,4})-(?<std_building_activity>\w{1,3})-(?<std_building_no_fiche>\d{1,3})-(?<title>.*?)(?:_(?<std_building_ind>[a-zA-Z]))?$";
string input = @"MIDI-PLA-GEN-067-2022V2_Screenshots_E
MIDI-PLA-GEN-067-2022V2_Screenshots";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}