$re = '/MIDI-(?<std_building_type>[a-zA-Z]{1,4})-(?<std_building_activity>\w{1,3})-(?<std_building_no_fiche>\d{1,3})-(?<title>.*?)(?:_(?<std_building_ind>[a-zA-Z]))?$/m';
$str = 'MIDI-PLA-GEN-067-2022V2_Screenshots_E
MIDI-PLA-GEN-067-2022V2_Screenshots';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);