const regex = /MIDI-(?<std_building_type>[a-zA-Z]{1,4})-(?<std_building_activity>\w{1,3})-(?<std_building_no_fiche>\d{1,3})-(?<title>.*?)(?:_(?<std_building_ind>[a-zA-Z]))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MIDI-(?<std_building_type>[a-zA-Z]{1,4})-(?<std_building_activity>\\w{1,3})-(?<std_building_no_fiche>\\d{1,3})-(?<title>.*?)(?:_(?<std_building_ind>[a-zA-Z]))?$', 'gm')
const str = `MIDI-PLA-GEN-067-2022V2_Screenshots_E
MIDI-PLA-GEN-067-2022V2_Screenshots`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}