import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:#)([\\p{L}\\p{N}_](?:(?:[\\p{L}\\p{N}_]|(?:\\.(?!\\.))){0,28}(?:[\\p{L}\\p{N}_]))?)";
final String string = "#mahdi123456789 khanzadi\n"
+ "#mahdi\n\n"
+ "#مهدیـmahisdfasdf.adfasdf.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}