re = /(?:#)([\p{L}\p{N}_](?:(?:[\p{L}\p{N}_]|(?:\.(?!\.))){0,28}(?:[\p{L}\p{N}_]))?)/m
str = '#mahdi123456789 khanzadi
#mahdi
#مهدیـmahisdfasdf.adfasdf.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end