const regex = /(?:#)([\p{L}\p{N}_](?:(?:[\p{L}\p{N}_]|(?:\.(?!\.))){0,28}(?:[\p{L}\p{N}_]))?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:#)([\\p{L}\\p{N}_](?:(?:[\\p{L}\\p{N}_]|(?:\\.(?!\\.))){0,28}(?:[\\p{L}\\p{N}_]))?)', 'gm')
const str = `#mahdi123456789 khanzadi
#mahdi
#مهدیـmahisdfasdf.adfasdf.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}