const regex = /(?(1)(\btest\b)|(\bpie\b))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(1)(\\btest\\b)|(\\bpie\\b))', 'gm')
const str = `test pie sdfds
test dsf sdfs
test sdfsdfsd pie
dfsdf test
dfsdfs test sdfsdf pie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}