$re = '/(?(1)(\btest\b)|(\bpie\b))/m';
$str = 'test pie sdfds
test dsf sdfs
test sdfsdfsd pie
dfsdf test
dfsdfs test sdfsdf pie';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);