re = /(?(1)(\btest\b)|(\bpie\b))/m
str = 'test pie sdfds
test dsf sdfs
test sdfsdfsd pie
dfsdf test
dfsdfs test sdfsdf pie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end