using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<tag>[A-Za-z0-9]+)\](?P<text>[А-Яа-яA-Za-z0-9- ,\.\(\)]+)(?=\[)";
string input = @"[m1]Эрэн-Хото [i](городской уезд автономного района)[/i][/m1]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}