re = /\[(?P<tag>[A-Za-z0-9]+)\](?P<text>[А-Яа-яA-Za-z0-9- ,\.\(\)]+)(?=\[)/m
str = '[m1]Эрэн-Хото [i](городской уезд автономного района)[/i][/m1]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end