$re = '~/(\w+)/[-a-z]+?/?(?:\?.*?)*(?:\s|$)~m';
$str = 'http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);