re = /\/(\w+)\/[-a-z]+?\/?(?:\?.*?)*(?:\s|$)/m
str = 'http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end