import Foundation
let pattern = #"/(\w+)/[-a-z]+?/?(?:\?.*?)*(?:\s|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.test.com/newyork/class-schedule http://www.test.com/location/newyork/class-schedule http://www.test.com/location/newyork/training http://www.test.com/location/newyork/training/
http://www.test.com/location/newyork/training/?abc=1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)