#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(https?://)?[A-Za-z0-9\-.]*(:\d+)?/[A-Za-z0-9\-.]*$"
Local $sString = "https://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt" & @CRLF & _
"http://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt" & @CRLF & _
"GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt" & @CRLF & _
"https://:80/ABCdef123-.txt" & @CRLF & _
"http://:80/ABCdef123-.txt" & @CRLF & _
"https://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt" & @CRLF & _
"http://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt" & @CRLF & _
"GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt" & @CRLF & _
"https:///ABCdef123-.txt" & @CRLF & _
"http:///ABCdef123-.txt" & @CRLF & _
"https://GACKOgacko123456789-gacko.domain.COM:80/" & @CRLF & _
"http://GACKOgacko123456789-gacko.domain.COM:80/" & @CRLF & _
"GACKOgacko123456789-gacko.domain.COM:80/" & @CRLF & _
"https://:80/" & @CRLF & _
"http://:80/" & @CRLF & _
"https://GACKOgacko123456789-gacko.domain.COM/" & @CRLF & _
"http://GACKOgacko123456789-gacko.domain.COM/" & @CRLF & _
"GACKOgacko123456789-gacko.domain.COM/" & @CRLF & _
"https:///" & @CRLF & _
"http:///" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")