package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?://)?[A-Za-z0-9\-.]*(:\d+)?/[A-Za-z0-9\-.]*$`)
var str = `https://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
http://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
https://:80/ABCdef123-.txt
http://:80/ABCdef123-.txt
https://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
http://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
https:///ABCdef123-.txt
http:///ABCdef123-.txt
https://GACKOgacko123456789-gacko.domain.COM:80/
http://GACKOgacko123456789-gacko.domain.COM:80/
GACKOgacko123456789-gacko.domain.COM:80/
https://:80/
http://:80/
https://GACKOgacko123456789-gacko.domain.COM/
http://GACKOgacko123456789-gacko.domain.COM/
GACKOgacko123456789-gacko.domain.COM/
https:///
http:///
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}