use strict;
my $str = 'https://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
http://GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
GACKOgacko123456789-gacko.domain.COM:80/ABCdef123-.txt
https://:80/ABCdef123-.txt
http://:80/ABCdef123-.txt
https://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
http://GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
GACKOgacko123456789-gacko.domain.COM/ABCdef123-.txt
https:///ABCdef123-.txt
http:///ABCdef123-.txt
https://GACKOgacko123456789-gacko.domain.COM:80/
http://GACKOgacko123456789-gacko.domain.COM:80/
GACKOgacko123456789-gacko.domain.COM:80/
https://:80/
http://:80/
https://GACKOgacko123456789-gacko.domain.COM/
http://GACKOgacko123456789-gacko.domain.COM/
GACKOgacko123456789-gacko.domain.COM/
https:///
http:///
';
my $regex = qr`^(https?://)?[A-Za-z0-9\-.]*(:\d+)?/[A-Za-z0-9\-.]*$`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}