#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)D601-10689-PC01"
Local $sString = "iPhone1,1" & @CRLF & _
"iPhone1,2" & @CRLF & _
"iPhone2,1" & @CRLF & _
"iPhone3,1" & @CRLF & _
"iPhone3,2" & @CRLF & _
"iPhone3,3" & @CRLF & _
"iPhone4,1" & @CRLF & _
"iPhone5,1" & @CRLF & _
"iPhone5,2" & @CRLF & _
"iPhone5,3" & @CRLF & _
"iPhone5,4" & @CRLF & _
"iPhone6,1" & @CRLF & _
"iPhone6,2" & @CRLF & _
"iPhone7,2" & @CRLF & _
"iPhone7,1" & @CRLF & _
"iPhone8,1" & @CRLF & _
"iPhone8,2" & @CRLF & _
"iPhone8,4" & @CRLF & _
"iPhone9,1" & @CRLF & _
"iPhone9,3" & @CRLF & _
"iPhone9,2" & @CRLF & _
"iPhone9,4" & @CRLF & _
"iPhone10,1" & @CRLF & _
"iPhone10,4" & @CRLF & _
"iPhone10,2" & @CRLF & _
"iPhone10,5" & @CRLF & _
"iPhone10,3" & @CRLF & _
"iPhone10,6" & @CRLF & _
"iPhone11,8" & @CRLF & _
"iPhone11,2" & @CRLF & _
"iPhone11,6" & @CRLF & _
"iPhone11,4" & @CRLF & _
"iPhone12,1" & @CRLF & _
"iPhone12,3" & @CRLF & _
"iPhone12,5" & @CRLF & _
"iPhone12,8" & @CRLF & _
"iPhone13,1" & @CRLF & _
"iPhone13,2" & @CRLF & _
"iPhone13,3" & @CRLF & _
"iPhone13,4" & @CRLF & _
"iPhone14,4" & @CRLF & _
"iPhone14,5" & @CRLF & _
"iPhone14,2" & @CRLF & _
"iPhone14,3" & @CRLF & _
"iPhone14,6" & @CRLF & _
"" & @CRLF & _
"iPad1,1" & @CRLF & _
"iPad1,1" & @CRLF & _
"iPad2,1" & @CRLF & _
"iPad2,2" & @CRLF & _
"iPad2,3" & @CRLF & _
"iPad2,4" & @CRLF & _
"iPad2,5" & @CRLF & _
"iPad2,6" & @CRLF & _
"iPad2,7" & @CRLF & _
"iPad3,1" & @CRLF & _
"iPad3,2" & @CRLF & _
"iPad3,3" & @CRLF & _
"iPad3,4" & @CRLF & _
"iPad3,5" & @CRLF & _
"iPad3,6" & @CRLF & _
"iPad4,1" & @CRLF & _
"iPad4,2" & @CRLF & _
"iPad4,3" & @CRLF & _
"iPad4,4" & @CRLF & _
"iPad4,5" & @CRLF & _
"iPad4,6" & @CRLF & _
"iPad4,7" & @CRLF & _
"iPad4,8" & @CRLF & _
"iPad4,9" & @CRLF & _
"iPad5,1" & @CRLF & _
"iPad5,2" & @CRLF & _
"iPad5,3" & @CRLF & _
"iPad5,4" & @CRLF & _
"iPad6,11" & @CRLF & _
"iPad6,12" & @CRLF & _
"iPad6,3" & @CRLF & _
"iPad6,4" & @CRLF & _
"iPad6,7" & @CRLF & _
"iPad6,8" & @CRLF & _
"iPad7,1" & @CRLF & _
"iPad7,11" & @CRLF & _
"iPad7,12" & @CRLF & _
"iPad7,12" & @CRLF & _
"iPad7,12" & @CRLF & _
"iPad7,2" & @CRLF & _
"iPad7,3" & @CRLF & _
"iPad7,4" & @CRLF & _
"iPad7,5" & @CRLF & _
"iPad7,6" & @CRLF & _
"iPad8,1" & @CRLF & _
"iPad8,10" & @CRLF & _
"iPad8,10" & @CRLF & _
"iPad8,10" & @CRLF & _
"iPad8,11" & @CRLF & _
"iPad8,12" & @CRLF & _
"iPad8,12" & @CRLF & _
"iPad8,12" & @CRLF & _
"iPad8,2" & @CRLF & _
"iPad8,3" & @CRLF & _
"iPad8,3" & @CRLF & _
"iPad8,3," & @CRLF & _
"iPad8,4" & @CRLF & _
"iPad8,4" & @CRLF & _
"iPad8,4" & @CRLF & _
"iPad8,5, " & @CRLF & _
"iPad8,6" & @CRLF & _
"iPad8,7" & @CRLF & _
"iPad8,7" & @CRLF & _
"iPad8,7" & @CRLF & _
"iPad8,8" & @CRLF & _
"iPad8,8" & @CRLF & _
"iPad8,8" & @CRLF & _
"iPad8,9" & @CRLF & _
"iPad11,1" & @CRLF & _
"iPad11,2" & @CRLF & _
"iPad11,2" & @CRLF & _
"iPad11,2" & @CRLF & _
"iPad11,3" & @CRLF & _
"iPad11,4" & @CRLF & _
"iPad11,4" & @CRLF & _
"iPad11,4" & @CRLF & _
"iPad11,6" & @CRLF & _
"iPad11,7" & @CRLF & _
"iPad11,7" & @CRLF & _
"iPad11,7" & @CRLF & _
"iPad12,1" & @CRLF & _
"iPad12,2" & @CRLF & _
"iPad12,2" & @CRLF & _
"iPad12,2" & @CRLF & _
"iPad13,1" & @CRLF & _
"iPad13,10" & @CRLF & _
"iPad13,11" & @CRLF & _
"iPad13,16" & @CRLF & _
"iPad13,17" & @CRLF & _
"iPad13,17" & @CRLF & _
"iPad13,2" & @CRLF & _
"iPad13,2" & @CRLF & _
"iPad13,2" & @CRLF & _
"iPad13,4" & @CRLF & _
"iPad13,5" & @CRLF & _
"iPad13,6" & @CRLF & _
"iPad13,7" & @CRLF & _
"iPad13,8" & @CRLF & _
"iPad13,9" & @CRLF & _
"iPad14,1" & @CRLF & _
"iPad14,2" & @CRLF & _
"iPad14,2" & @CRLF & _
"" & @CRLF & _
"AppleTV1,1" & @CRLF & _
"AppleTV2,1" & @CRLF & _
"AppleTV3,1" & @CRLF & _
"AppleTV3,2" & @CRLF & _
"AppleTV5,3" & @CRLF & _
"AppleTV6,2" & @CRLF & _
"AppleTV11,1"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)