use strict;
my $str = 'iPhone1,1
iPhone1,2
iPhone2,1
iPhone3,1
iPhone3,2
iPhone3,3
iPhone4,1
iPhone5,1
iPhone5,2
iPhone5,3
iPhone5,4
iPhone6,1
iPhone6,2
iPhone7,2
iPhone7,1
iPhone8,1
iPhone8,2
iPhone8,4
iPhone9,1
iPhone9,3
iPhone9,2
iPhone9,4
iPhone10,1
iPhone10,4
iPhone10,2
iPhone10,5
iPhone10,3
iPhone10,6
iPhone11,8
iPhone11,2
iPhone11,6
iPhone11,4
iPhone12,1
iPhone12,3
iPhone12,5
iPhone12,8
iPhone13,1
iPhone13,2
iPhone13,3
iPhone13,4
iPhone14,4
iPhone14,5
iPhone14,2
iPhone14,3
iPhone14,6
iPad1,1
iPad1,1
iPad2,1
iPad2,2
iPad2,3
iPad2,4
iPad2,5
iPad2,6
iPad2,7
iPad3,1
iPad3,2
iPad3,3
iPad3,4
iPad3,5
iPad3,6
iPad4,1
iPad4,2
iPad4,3
iPad4,4
iPad4,5
iPad4,6
iPad4,7
iPad4,8
iPad4,9
iPad5,1
iPad5,2
iPad5,3
iPad5,4
iPad6,11
iPad6,12
iPad6,3
iPad6,4
iPad6,7
iPad6,8
iPad7,1
iPad7,11
iPad7,12
iPad7,12
iPad7,12
iPad7,2
iPad7,3
iPad7,4
iPad7,5
iPad7,6
iPad8,1
iPad8,10
iPad8,10
iPad8,10
iPad8,11
iPad8,12
iPad8,12
iPad8,12
iPad8,2
iPad8,3
iPad8,3
iPad8,3,
iPad8,4
iPad8,4
iPad8,4
iPad8,5,
iPad8,6
iPad8,7
iPad8,7
iPad8,7
iPad8,8
iPad8,8
iPad8,8
iPad8,9
iPad11,1
iPad11,2
iPad11,2
iPad11,2
iPad11,3
iPad11,4
iPad11,4
iPad11,4
iPad11,6
iPad11,7
iPad11,7
iPad11,7
iPad12,1
iPad12,2
iPad12,2
iPad12,2
iPad13,1
iPad13,10
iPad13,11
iPad13,16
iPad13,17
iPad13,17
iPad13,2
iPad13,2
iPad13,2
iPad13,4
iPad13,5
iPad13,6
iPad13,7
iPad13,8
iPad13,9
iPad14,1
iPad14,2
iPad14,2
AppleTV1,1
AppleTV2,1
AppleTV3,1
AppleTV3,2
AppleTV5,3
AppleTV6,2
AppleTV11,1';
my $regex = qr/D601-10689-PC01/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";