# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"D601-10689-PC01"
test_str = ("iPhone1,1\n"
"iPhone1,2\n"
"iPhone2,1\n"
"iPhone3,1\n"
"iPhone3,2\n"
"iPhone3,3\n"
"iPhone4,1\n"
"iPhone5,1\n"
"iPhone5,2\n"
"iPhone5,3\n"
"iPhone5,4\n"
"iPhone6,1\n"
"iPhone6,2\n"
"iPhone7,2\n"
"iPhone7,1\n"
"iPhone8,1\n"
"iPhone8,2\n"
"iPhone8,4\n"
"iPhone9,1\n"
"iPhone9,3\n"
"iPhone9,2\n"
"iPhone9,4\n"
"iPhone10,1\n"
"iPhone10,4\n"
"iPhone10,2\n"
"iPhone10,5\n"
"iPhone10,3\n"
"iPhone10,6\n"
"iPhone11,8\n"
"iPhone11,2\n"
"iPhone11,6\n"
"iPhone11,4\n"
"iPhone12,1\n"
"iPhone12,3\n"
"iPhone12,5\n"
"iPhone12,8\n"
"iPhone13,1\n"
"iPhone13,2\n"
"iPhone13,3\n"
"iPhone13,4\n"
"iPhone14,4\n"
"iPhone14,5\n"
"iPhone14,2\n"
"iPhone14,3\n"
"iPhone14,6\n\n"
"iPad1,1\n"
"iPad1,1\n"
"iPad2,1\n"
"iPad2,2\n"
"iPad2,3\n"
"iPad2,4\n"
"iPad2,5\n"
"iPad2,6\n"
"iPad2,7\n"
"iPad3,1\n"
"iPad3,2\n"
"iPad3,3\n"
"iPad3,4\n"
"iPad3,5\n"
"iPad3,6\n"
"iPad4,1\n"
"iPad4,2\n"
"iPad4,3\n"
"iPad4,4\n"
"iPad4,5\n"
"iPad4,6\n"
"iPad4,7\n"
"iPad4,8\n"
"iPad4,9\n"
"iPad5,1\n"
"iPad5,2\n"
"iPad5,3\n"
"iPad5,4\n"
"iPad6,11\n"
"iPad6,12\n"
"iPad6,3\n"
"iPad6,4\n"
"iPad6,7\n"
"iPad6,8\n"
"iPad7,1\n"
"iPad7,11\n"
"iPad7,12\n"
"iPad7,12\n"
"iPad7,12\n"
"iPad7,2\n"
"iPad7,3\n"
"iPad7,4\n"
"iPad7,5\n"
"iPad7,6\n"
"iPad8,1\n"
"iPad8,10\n"
"iPad8,10\n"
"iPad8,10\n"
"iPad8,11\n"
"iPad8,12\n"
"iPad8,12\n"
"iPad8,12\n"
"iPad8,2\n"
"iPad8,3\n"
"iPad8,3\n"
"iPad8,3,\n"
"iPad8,4\n"
"iPad8,4\n"
"iPad8,4\n"
"iPad8,5, \n"
"iPad8,6\n"
"iPad8,7\n"
"iPad8,7\n"
"iPad8,7\n"
"iPad8,8\n"
"iPad8,8\n"
"iPad8,8\n"
"iPad8,9\n"
"iPad11,1\n"
"iPad11,2\n"
"iPad11,2\n"
"iPad11,2\n"
"iPad11,3\n"
"iPad11,4\n"
"iPad11,4\n"
"iPad11,4\n"
"iPad11,6\n"
"iPad11,7\n"
"iPad11,7\n"
"iPad11,7\n"
"iPad12,1\n"
"iPad12,2\n"
"iPad12,2\n"
"iPad12,2\n"
"iPad13,1\n"
"iPad13,10\n"
"iPad13,11\n"
"iPad13,16\n"
"iPad13,17\n"
"iPad13,17\n"
"iPad13,2\n"
"iPad13,2\n"
"iPad13,2\n"
"iPad13,4\n"
"iPad13,5\n"
"iPad13,6\n"
"iPad13,7\n"
"iPad13,8\n"
"iPad13,9\n"
"iPad14,1\n"
"iPad14,2\n"
"iPad14,2\n\n"
"AppleTV1,1\n"
"AppleTV2,1\n"
"AppleTV3,1\n"
"AppleTV3,2\n"
"AppleTV5,3\n"
"AppleTV6,2\n"
"AppleTV11,1")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.