#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\.]*\.[^\.]*\.[^\.]*?([0-9])"
Local $sString = "AR0.RRPG.105" & @CRLF & _
"AR6.TR0.500" & @CRLF & _
"AR0.GGF0.2FEH" & @CRLF & _
"AR0.DER.M15" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")