re = /^[^\.]*\.[^\.]*\.[^\.]*?([0-9])/m
str = 'AR0.RRPG.105
AR6.TR0.500
AR0.GGF0.2FEH
AR0.DER.M15
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end