import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\.]*\\.[^\\.]*\\.[^\\.]*?([0-9])";
final String string = "AR0.RRPG.105\n"
+ "AR6.TR0.500\n"
+ "AR0.GGF0.2FEH\n"
+ "AR0.DER.M15\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}