const regex = /(?:‘|\s*(?!^))([^,\r\n’]+)(?=[^\r\n’]*’)(?:(,)|’)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:‘|\\s*(?!^))([^,\\r\\n’]+)(?=[^\\r\\n’]*’)(?:(,)|’)', 'gm')
const str = `‘verdichten’
‘verdichten, verstopfen’
‘dunkel, finster, wolkig’
‘fort sein, verloren sein, verloren’
‘von den Nymph ergriffen, verzückt, verrückt’
‘der sich halten kann, halten kann’`;
const subst = `[[$1]]$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);