const regex = /(\d+)(?<!10)\.(\d+)(?<!192\.168)(?<!172\.(1[6-9]|2\d|3[0-1]))\.(\d+)\.(\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(?<!10)\\.(\\d+)(?<!192\\.168)(?<!172\\.(1[6-9]|2\\d|3[0-1]))\\.(\\d+)\\.(\\d+)', 'g')
const str = `10.10.2.246
10.10.2.246
10.10.2.246
169.54.137.73
10.10.2.246
10.10.2.246
10.10.2.246
188.172.213.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}