using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s(-\S+)";
string input = @"слово1 слово2 -минус1 слово3.1-слово3.2 -минус фраза -мин ус2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}