package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s(-\S+)`)
var str = `слово1 слово2 -минус1 слово3.1-слово3.2 -минус фраза -минус2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}