$re = '/\s(-\S+)/';
$str = 'слово1 слово2 -минус1 слово3.1-слово3.2 -минус фраза -минус2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);