package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[A-Z](?:[^A-Za-z\r\n])*){2,}$`)
var str = `THE QUEEN’S HAND
THE QUEEN’s HAND
THE QUEEN’ss HAND
THE QUEEN’sAAs HAND
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}