re = /^(?:[A-Z](?:[^A-Za-z\r\n])*){2,}$/m
str = 'THE QUEEN’S HAND
THE QUEEN’s HAND
THE QUEEN’ss HAND
THE QUEEN’sAAs HAND
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end