$re = '/^(?:[A-Z](?:[^A-Za-z\r\n])*){2,}$/m';
$str = 'THE QUEEN’S HAND
THE QUEEN’s HAND
THE QUEEN’ss HAND
THE QUEEN’sAAs HAND
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);