using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ERROR|WARNING|INFO):([^:]+):(\d+),(\d+):(.+)";
string input = @"ERROR:src/sample.js:10,12:This is the message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}