const regex = /(ERROR|WARNING|INFO):([^:]+):(\d+),(\d+):(.+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ERROR|WARNING|INFO):([^:]+):(\\d+),(\\d+):(.+)', 'gm')
const str = `ERROR:src/sample.js:10,12:This is the message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}