package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ERROR|WARNING|INFO):([^:]+):(\d+),(\d+):(.+)`)
var str = `ERROR:src/sample.js:10,12:This is the message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}