using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z]\w*$";
string input = @"dasdasdasd
askdhka102131a
#asdaw4324\
-asds
1
asdasd
1212
adqweqwqqeqwe
asdasd
asdasd123123123
1233adasdsad
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}