import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z]\\w*$";
final String string = "dasdasdasd\n"
+ "askdhka102131a\n"
+ "#asdaw4324\\\n"
+ "-asds\n"
+ "1\n"
+ "asdasd\n"
+ "1212\n"
+ "adqweqwqqeqwe\n"
+ "asdasd\n"
+ "asdasd123123123\n"
+ "1233adasdsad\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}