// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z]\w*$").unwrap();
let string = "dasdasdasd
askdhka102131a
#asdaw4324\\
-asds
1
asdasd
1212
adqweqwqqeqwe
asdasd
asdasd123123123
1233adasdsad
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}