# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(Diskusija:\n|\* )|($|^)|($)/$2$3/gm;t' <<< "Diskusija:
* Kādēļ Baiba turpina Laines kiberterorizēšanu?
* Kā jūtas Laine, uzzinot, ka viņas sociālajos tīklos ir kaut kas tāds publicēts?
* Kādēļ Renārs uzliek Like Baibas ierakstam?"