use strict;
my $str = 'Diskusija:
* Kādēļ Baiba turpina Laines kiberterorizēšanu?
* Kā jūtas Laine, uzzinot, ka viņas sociālajos tīklos ir kaut kas tāds publicēts?
* Kādēļ Renārs uzliek Like Baibas ierakstam?';
my $regex = qr/(Diskusija:\n|\* )|($|^)|($)/mp;
my $subst = '$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";