const regex = /(Diskusija:\n|\* )|($|^)|($)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Diskusija:\\n|\\* )|($|^)|($)', 'gm')
const str = `Diskusija:
* Kādēļ Baiba turpina Laines kiberterorizēšanu?
* Kā jūtas Laine, uzzinot, ka viņas sociālajos tīklos ir kaut kas tāds publicēts?
* Kādēļ Renārs uzliek Like Baibas ierakstam?`;
const subst = `$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);