const regex = /\\[^\\]+(?=\.exe)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\[^\\\\]+(?=\\.exe)', 'gm')
const str = `R:\\soft\\port\\application\\123 - pic convert [5791G]\\123 - pic convert [5791G].exe
R:\\soft\\port\\application\\Jane's homemade recipe [981GF]\\Jane's homemade recipe [981GF].exe
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);